猫头鹰-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

SSL/TLS中间人攻击漏洞(CCS注入)

WASC Threat Classification

发现时间:

2016-08-09

漏洞类型:

其他

所属建站程序:

其他

所属服务器类型:

其他

所属编程语言:

其他

描述:

目标存在SSL/TLS中间人攻击漏洞(CCS注入)

OpenSSLOpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。

OpenSSL中存在安全漏洞,该漏洞源于程序没有正确限制ChangeCipherSpec消息的处理。攻击者可借助特制的TLS握手利用该漏洞实施中间人攻击,在OpenSSL-to-OpenSSL通信过程中使用零长度的主密钥,劫持会话或获取敏感消息。以下版本受到影响:OpenSSL 0.9.8y及之前的版本,1.0.0m之前的1.0.0版本,1.0.1h之前的1.0.1版本。

CVE-2014-0224

CNNVD-201406-080


危害:

攻击者可借助特制的TLS握手利用该漏洞实施中间人攻击,在OpenSSL-to-OpenSSL通信过程中使用零长度的主密钥,劫持会话或获取敏感消息。

解决方案:

升级openssl到最新版本,下载地址https://www.openssl.org/

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载,如果您因为技术原因无法修复漏洞,请进入360站长社区寻求帮助
对该漏洞进行评论
[共 0 条]
还可以输入120
 
输入验证码: